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Chapter 7 Interoperability
Interoperability refers to the interchange 
of data between software tools and/or 
databases. In eXpress, models can be 
populated using data that has been im-
ported from external sources. eXpress 
data can also be exported in various 
formats (MS-Excel, XML, etc.). This 
chapter will not attempt extensive cover-
age of this topic, but will rather focus on 
a few of the most commonly used import 
and export capabilities. For additional 
information, please refer to the eXpress 
Online Help or other DSI documentation.

Importing Data
This section will address several of the most common types of data that can 
be imported into the eXpress modeling environment. In these examples, it is 
assumed that the data has been formatted in a Microsoft Excel spreadsheet 
with column description headers denoting objects, failure modes, (affected) 
functions, failure mode ratios, reliability, failure effects, severity, tests, etc..

To successfully import data from external data sources, it is very important 
that the names and nomenclature are identical. Most problems with imports 
can be traced back to an extra “ “ (space) somewhere in a name or attribute.

When importing attribute values, it is necessary that the attributes already 
be defined within the eXpress model so that the imported data will have a 
corresponding attribute field to which it can be “mapped”.

Design template data 
can be imported into 
many models, thus 
ensuring data consis-
tency across an entire 
system design.

Applying Attribute using Design Templates
One extremely important feature of eXpress is the ability to import attribute 
definitions from a predefined design template. This is particularly useful for 
systems that are comprised of a large number of models. The use of design 
templates enforces data integrity by ensuring that attribute definitions are 
consistent across all models. Multiple templates may also be created to con-
tain attribute definitions that are unique to particular projects or programs. 

Design templates are created by publishing the attributes from a model in 
which all the attributes have been defined. See the section “Publishing At-
tribute Design Templates” below for a brief description of this feature.

For this import, an attribute design template file must first be provided or cre-
ated (all eXpress design template files utilize the filename extension “.ext”). 
If a single design template file will be used to import attribute definitions into 
several eXpress models, it should be saved in a location that can be easily 
accessed by the users responsible for these models.

In the example that follows, it is assumed that the design document (model) 
has already been opened within eXpress and that the import action is ready 
to be initiated.



86
Interoperability
Chapter 7 express 87

Quick Start Guide 

To import attribute deýnitions from a design template:

Action Response

Select “Import>Data Source Admin-
istration” from the File pull-down 
menu. 

The “Data Source Administration” 
dialog will appear (as shown at 
right).

Click on the “New” button. The “Create Data Source“ dialog 
will appear.

Select “Design Template” and click 
on the “OK” button. 

A new entry will be added to the 
tree on the left side of the “Data 
Source Administration” dialog (see 
screen depicted at bottom right).

Click on the “...” button to the right 
of the Template File field.

A file selection dialog will appear.

Select the desired design template 
file.

File path and name (with “.ext” 
extension) will now be listed in the 
Template File field.

Click on the “Update Now” button. The data will be imported.

Click on the “Done” button. The “Data Source Administration” 
dialog will close.

Note: The “Update Interval” field is used to specify how frequently 
eXpress is to scan and automatically update imported data when 
the source file has been modified.

The Web Service field allows data to be imported from a design template 
that has been posted on a web site. If this option is selected, the web site 
address and path must be correctly entered into this field.
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Importing Reliability Data
Before reliability data can be imported into an eXpress model, the model 
must first have a “Reliability” attribute definition. This can either be manu-
ally created (see Chapter 3) or automatically created by importing a design 
template that contains the corresponding attribute definition (See the section 
“Applying attribute Templates” earlier in this chapter).

Here is a typical format for a MS Excel spreadsheet containing reliability 
data:

Object Failure Rate

Band Pass Filter 13.23

Power Supply 45.38

The Failure Rate may be specified as Mean-Time-Between-Failures (MTBF) 
if the Reliability attribute in the eXpress model has been set up as a MTBF.

In order for data to be correctly imported, the object names in the spread-
sheet must be identical to those in the eXpress model. Failure rates can 
also be imported for functions (in this case, the function names in the 
spreadsheet must match the function names in the eXpress model).

To correlate data (object/function names) 
between the eXpress model and the Excel 
spreadsheet, it is recommended that Basic 
Design Statistics subreports be used to 
obtain the names of all objects and func-
tions in the model. These names can then 
be copied into the data columns in the Excel 
spreadsheet, thereby ensuring that the data 
can be correctly “mapped” during import.

Excel data that is to 
be imported must be 
contiguous without 
any empty rows or 
columns between 
data entries.

Once the import is complete, verify that the attribute definitions have 
imported correctly.  This is done by selecting the “Attributes>Define” from 
the Design pull-down menu and then reviewing the entries in the Define At-
tributes dialog. 

The import of attribute definitions can also be verified by highlighting one of 
the elements for which an attribute definition has been imported (e.g., an ob-
ject), selecting the Attributes context panel and then reviewing the attributes 
that are available for that type of element. However, doing this will only show 
attributes that have been defined for the selected element type (object). It 
will not show the attributes that have been defined for other element types 
(failure modes, failure effects, tests, etc.), although these definitions can also 
be verified using the Attributes panel that corresponds to that element.
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To import object reliability data from an Excel spreadsheet:

Action Response

Select “Import>Data Source Admin-
istration” from the File pull-down 
menu. 

The “Data Source Administration” 
dialog will appear (as shown at 
right).

Click on the “New” button. The “Create Data Source“ dialog 
will appear.

Select “Spreadsheet Attributes” and 
click on the “OK” button.  

A new entry will be added to the 
“Data Source Administration” dialog 
(see bottom right).

Type a title into the “Data Source 
Name” field.

This will be the name of the import.

Click on the yellow folder beside 
the Filename field and select the 
spreadsheet file containing the reli-
ability attributes to be imported.

File path and name (with “.xls” 
extension) will now be listed in the 
Filename field.

Select the sheet/column from 
which data is to be imported, the 
column containing the “key” data, 
the header data row, and the rows 
containing the data to be imported.

Indicates the locations of data 
within the selected spreadsheet file.

Use the “eXpress Target” fields to 
specify what model data will be 
compared to the “key” data, as well 
as what attribute will be imported.

Indicates the locations and types of 
data within the eXpress design file.

Click on the “Update Now” button. The data will be imported.

Click on the “Done” button. The “Data Source Administration” 
dialog will close.
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Importing Failure Mode Data
To import failure modes from an Excel spreadsheet, the data must also be 
contiguous (just as with reliability data imports). The spreadsheet cannot 
contain blank rows or columns separating data entries. Although only the 
object names, failure mode names and the failure mode percentages need 
to be defined in order for failure modes to be imported, it is recommended 
that affected functions also be included. To avoid error messages within eX-
press, the failure mode percentages should add up to 100% for each object. 
Here’s a simple example of what an Excel spreadsheet might look like for a 
failure mode import.

Object Failure Mode Affected Functions %

BPF Output Cap Open BPF - Output1 25

BPF Output Cap Short BPF - Output1 25

BPF Loss of GND BPF - Output2 50

PS Loss of Regulation PS - AC Output 80

PS Loss of DC PS - DC Output 20

When a failure mode can affect (degrade) more than one function, the 
names of the affected functions should be entered on different lines within 
the same cell (this can be done using the “Alt+Enter” command in Excel). 

In some cases, a portion of an object’s failure rate may not be assigned 
or apportioned to a specific failure mode. In these cases, the failure mode 
percentages for that object will not add up to 100%. Although this is 
acceptable, eXpress will issue a blue “Possible Error” message on the Error 
Checker toolbar.

It is not necessary that the import spreadsheet list affected functions 
(as shown in the example above). However, if affected functions are not 

defined within the import file, the functions will be set to default values (any 
differences will have to be manually selected after import). eXpress will 
issue a blue “Possible Error” message in the Error Checker toolbar if no 
affected functions are selected for a failure mode.

It is important to note that the names given to the affected functions in the 
Excel spreadsheet must not only match the existing names in the eXpress 
model, but also be preceded by the object name. For example, an object 
named “BPF” with an output function named “Output1” must be represented 
in the spreadsheet as “BPF - Output1” with a space before and after the 
hyphen (“-”).

If tests will later be defined for all imported failure modes, it must be remem-
bered that if an object’s failure mode percentages add up to less than 100%, 
then the overall detection coverage will never be 100% for that design (since 
a portion of at least one object will remain undetected). If test coverage is 
assigned to functions, however, this is not an issue. 

Refer to the eXpress Online Help for additional information about Failure 
Modes (including the calculation of failure probabilities using “Failure Mode 
Precedence”).

Each type of import (failure mode, failure effect, test, etc.) 
has special settings specific to that import type. For example: 
Failure Modes can be “mapped” to affected functions, failure 
effects can be mapped to individual objects or to an entire 
design (2 separate imports actions required to get both), and 
tests can be imported as either Inspection or Signature tests. 
See the eXpress Online Help for more details on each import 
capability.
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To import failure modes from an Excel spreadsheet:
Action Response

Select “Import>Data Source Admin-
istration” from the File menu. 

The “Data Source Administration” 
dialog will appear (shown at right).

Click on the “New” button. The “Create Data Source“ dialog 
will appear.

Select “Spreadsheet Failure Modes” 
and click on the “OK” button.  

A new entry will be added to the 
“Data Source Administration” dialog.

Type a title into the “Data Source 
Name” field.

This will be the name of the import.

Click on the square button beside 
the “Data Source Filename” field 
and select the spreadsheet file con-
taining the failure modes data.

File path and name (with “.xls” 
extension) will now be listed in the 
“Data Source Filename” field.

Select the spreadsheet columns 
containing the failure mode name, 
failure mode percentage, and af-
fected functions list.

Indicates the locations of data 
within the selected spreadsheet file.

Click on the “Affected Function 
Setup” button.

The “Import Affected Functions 
Setup” dialog will appear.

Select the relationships (Always, 
Sometimes, Never) to be applied to 
affected functions. Click on “OK”.

Indicates the initial and imported 
relationship settings (as well as the 
use of override characters).

Select the field type and column for 
the “key” data.

Indicates the locations and types of 
data within the eXpress design file.

Click on the “Update Now” button. The data will be imported.

Click on the “Done” button. The dialog will close.
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Importing Tests
See the previous examples to get a general overview of the import process. 
This section will only provide the steps necessary for importing tests (without 
the associated graphics). For additional details, refer to the eXpress Online 
Help.

Importing Failure Effect Data
See the previous examples to get a general overview of the import process. 
This section will only provide the steps necessary for importing failure effects 
(without the associated graphics). For additional details, refer to the eXpress 
Online Help.

Action Response

Select “Import>Data Source Admin-
istration” from the File menu. 

The “Data Source Administration” 
dialog will appear (shown at right).

Click on the “New” button. The “Create Data Source“ dialog 
will appear.

Select “Failure Effect Import” and 
click on the “OK” button. 

The Data Source Administration 
window appears.

Type a title into the “Data Source 
Name” field.

This will be the name of the import.

Click on the square button beside 
the “Data Source Filename” field 
and select the spreadsheet file con-
taining the failure effect data.

File path and name (with “.xls” 
extension) will now be listed in the 
“Data Source Filename” field.

Select the spreadsheet columns 
containing the failure effect name, 
causes, and severity.

Indicates the locations of data 
within the selected spreadsheet file.

Select the field type and column for 
the object “key” data.

Indicates the locations and types of 
data within the eXpress design file.

Select the type of failure effects 
(object / design) to be imported.

The import setup has been finished.

Click on the “Update Now” button. The data will be imported.

Click on the “Done” button. The dialog will close.

Action Response

Select “Import>Data Source Admin-
istration” from the File menu. 

The “Data Source Administration” 
dialog will appear (shown at right).

Click on the “New” button. The “Create Data Source“ dialog 
will appear.

Select “Test Import” and click on the 
“OK” button.  

The Data Source Administration 
window appears.

Type a title into the “Data Source 
Name” field.

This will be the name of the import.

Click on the square button beside 
the “Data Source Filename” field 
and select the spreadsheet file 
containing the test data.

File path and name (with “.xls” 
extension) will now be listed in the 
“Data Source Filename” field.

Select the spreadsheet columns 
containing the test name & cover-
age.

Indicates the locations of source 
data within the selected spread-
sheet file.

Select the column for the object 
“key” data.

Indicates the locations and types of 
data within the eXpress design file.

Select the destination test set and 
test type to be created.

Either Signature or Inspection tests 
may be imported.

Click on the “Update Now” button. The data will be imported.

Click on the “Done” button. The dialog will close.


